Browser compatibility guide

Bugsnag’s JavaScript notifier supports a wide range of browsers.

Support matrix

Browser Support version range
Chrome 30+
IE 8+
Edge 14+
Firefox 31+
Safari 6.2+
iOS Safari 8+
Android Browser 4.1+
Opera 18+

* Note: This list covers all browsers and versions that we have successfully tested. Bugsnag JavaScript works on many older browsers not listed here.

Customizing browser support

By default, Bugsnag JavaScript projects only report errors from the browsers listed above. Although the notifier supports older browsers, the amount of debugging information surrounding errors is limited. Therefore grouping and deduplication is impacted, as well as the quality of the error reports.

If you do wish to report errors from older browser versions, adjust the “Discard errors from legacy browsers” setting in your Project settings:

Discard errors from legacy browsers